summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-02 12:38:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-03-02 21:46:39 +0100
commit0c729ef4e361f2fe396a44bd138a693324abfc4a (patch)
treee67937db5ea6fb6ab5102595855804823d10ec22 /gnu
parent71053e1477b9f207072e64e831c6f55211cf6022 (diff)
gnu: icedtea-8: Do not embed build time.
* gnu/packages/java.scm (icedtea-8)[source]: Modify snippet to erase the embedded build time.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index cf4ba69d6a..1ff106cb99 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
@@ -855,10 +855,15 @@ IcedTea build harness.")
"02vmxa6gc6gizcri1fy797qmmm9y77vgi7gy9pwkk4agcw4zyr5p"))
(modules '((guix build utils)))
(snippet
- '(substitute* "Makefile.am"
- ;; do not leak information about the build host
- (("DISTRIBUTION_ID=\"\\$\\(DIST_ID\\)\"")
- "DISTRIBUTION_ID=\"\\\"guix\\\"\"")))))
+ '(begin
+ (substitute* "acinclude.m4"
+ ;; Do not embed build time
+ (("(DIST_ID=\"Custom build).*$" _ prefix)
+ (string-append prefix "\"\n"))
+ ;; Do not leak information about the build host
+ (("DIST_NAME=\"\\$build_os\"")
+ "DIST_NAME=\"guix\""))
+ #t))))
(arguments
(substitute-keyword-arguments (package-arguments icedtea-7)
((#:configure-flags flags)