summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2017-04-19 06:14:44 +0800
committerArun Isaac <arunisaac@systemreboot.net>2017-04-19 22:13:03 +0530
commit11f8e028d2fafc77be2eb58ced1680cb77b9b952 (patch)
tree68b6d2ea1618b52151b5e1d9e753bfd1097e91f9 /gnu
parenta35136cb564123932dbab2e3f319b344ecdca555 (diff)
gnu: emacs-exwm: Let shell wrapper work with arguments.
* gnu/packages/emacs.scm (emacs-exwm): Pass shell wrapper arguments to emacs. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6eb8751ad9..68bac8b41c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4475,7 +4475,7 @@ It should enable you to implement low-level X11 applications.")
(format #t "#!~a ~@
export DISPLAY=:0 ~@
~a +SI:localuser:$USER ~@
- exec ~a --exit-with-session ~a --eval '~s' ~%"
+ exec ~a --exit-with-session ~a \"$@\" --eval '~s' ~%"
(string-append (assoc-ref inputs "bash") "/bin/sh")
(string-append (assoc-ref inputs "xhost") "/bin/xhost")
(string-append (assoc-ref inputs "dbus") "/bin/dbus-launch")