summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-03-11 15:00:50 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-12 10:28:06 +1000
commit545d0789fc56059b9543bdb1a6d194eb1d0b40ed (patch)
tree8ad19c02d6763d875b4f7e10c343135aab527d2d /gnu
parentaa84100011b0f77516a23774eeade38ec1ae944c (diff)
gnu: Add r-matrixmodels.
* gnu/packages/statistics.scm (r-matrixmodels): New variable. Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index dbfa7dcd17..9f546f49bd 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4511,3 +4511,23 @@ decompositions of such matrices, and solutions of linear systems.")
"Written in C++ using @code{Rcpp}, this package provides a collection of
metrics for evaluating models.")
(license license:gpl2+)))
+
+(define-public r-matrixmodels
+ (package
+ (name "r-matrixmodels")
+ (version "0.4-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "MatrixModels" version))
+ (sha256
+ (base32
+ "0cyfvhci2p1vr2x52ymkyqqs63x1qchn856dh2j94yb93r08x1zy"))))
+ (properties `((upstream-name . "MatrixModels")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/MatrixModels")
+ (synopsis "Modelling with sparse and dense matrices")
+ (description
+ "This package models with sparse and dense matrix matrices,
+using modular prediction and response module classes.")
+ (license license:gpl2+)))