summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-03-11 11:50:25 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-11 11:51:50 +1000
commit7711f614502948274ceaf1c7547d8abe40b81c9b (patch)
tree059b789185c247c9c510acdb8ef3385acf843809 /gnu
parentd4cebae286fec90deae7c0cb829c8d57218c63fc (diff)
gnu: Add r-pbapply.
* gnu/packages/statistics.scm (r-pbapply): New variable. Co-authored-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 6045c796d2..6ab64a5c8f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4401,3 +4401,23 @@ no random-effects models. Many (150+) models and distributions are estimated
by maximum likelihood estimation (MLE) or penalized MLE, using Fisher scoring.
VGLMs can be loosely thought of as multivariate generalised linear models.")
(license license:gpl2+)))
+
+(define-public r-pbapply
+ (package
+ (name "r-pbapply")
+ (version "1.3-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "pbapply" version))
+ (sha256
+ (base32
+ "1sdmjlnwxb99f95g5v8k8mirrkzw99yig377v0qi9lzwjgd6fqqr"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/psolymos/pbapply")
+ (synopsis "Adding progress bar to apply functions")
+ (description
+ "This lightweight package that adds progress bar to vectorized R
+functions apply. The implementation can easily be added to functions where
+showing the progress is useful e.g. bootstrap.")
+ (license license:gpl2)))