summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-01-19 19:55:03 +0100
committerBen Woodcroft <donttrustben@gmail.com>2017-03-11 10:43:25 +1000
commita1f2668e6c0e3545ee2272edcab1a8db9d43b489 (patch)
tree84f3bd7c203981081f632cced2f5e4418e81a5cf /gnu
parent1721fb4fe79eecc8061c7bcdfe45c3503627587f (diff)
gnu: Add r-flexmix.
* gnu/packages/statistics.scm (r-flexmix): New variable. Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 333b1b6894..06872fdaec 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4209,3 +4209,27 @@ original public code has been corrected.")
models. The functionality is experimental and the user interface is likely
to change in the future.")
(license license:gpl2)))
+
+(define-public r-flexmix
+ (package
+ (name "r-flexmix")
+ (version "2.3-13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "flexmix" version))
+ (sha256
+ (base32
+ "1i205yw3kkxs27gqcs6zx0c2mh16p332a2p06wq6fdzb20bazg3z"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-modeltools" ,r-modeltools)))
+ (home-page "http://cran.r-project.org/web/packages/flexmix")
+ (synopsis "Flexible mixture modeling")
+ (description
+ "This package implements a general framework for finite mixtures of
+regression models using the EM algorithm. FlexMix provides the E-step and
+all data handling, while the M-step can be supplied by the user to easily
+define new models. Existing drivers implement mixtures of standard linear
+models, generalized linear models and model-based clustering.")
+ (license license:gpl2+)))