summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-15 18:12:31 -0400
committerLeo Famulari <leo@famulari.name>2017-04-17 13:57:01 -0400
commitb754c6121bc95c5c5f7409c93c69cd0207888723 (patch)
tree59cd2007a2c9f6946d323571757c44311a7e5453 /gnu
parent2f4a58b512972975257d664e54fbc28e8a0c72fe (diff)
gnu: Add libnftnl.
* gnu/packages/linux.scm (libnftnl): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4e1aa0b143..7a744ede6f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3733,3 +3733,28 @@ constructing of both the Netlink header and TLVs that are repetitive and easy to
get wrong. This library aims to provide simple helpers that allows you to
re-use code and to avoid re-inventing the wheel.")
(license license:lgpl2.1+)))
+
+(define-public libnftnl
+ (package
+ (name "libnftnl")
+ (version "1.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.netfilter.org/projects/libnftnl/files/"
+ "libnftnl-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "10irjrylcfkbp11617yr19vpfhgl54w0kw02jhj0i1abqv5nxdlv"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libmnl" ,libmnl)))
+ (home-page "https://www.netfilter.org/projects/libnftnl/index.html")
+ (synopsis "Netlink programming interface to the Linux nf_tables subsystem")
+ (description "Libnftnl is a userspace library providing a low-level netlink
+programming interface to the in-kernel nf_tables subsystem. The library
+libnftnl has been previously known as libnftables. This library is currently
+used by nftables.")
+ (license license:gpl2+)))