summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-04 06:17:42 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-11 13:46:40 +0200
commita99e7f524e5984fc4a696928c02442a1cc400945 (patch)
treebbca8a8577e0899a66e45aa05215318e1435257a /gnu
parent6d53111385b804b7eb7e4f414dc1c02d30848515 (diff)
gnu: Add emacs-evil-nerd-commenter.
* gnu/packages/emacs-xyz.scm (emacs-evil-nerd-commenter): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ece6a8a1b8..afaf1536dd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5786,6 +5786,29 @@ line, including functions for version control with Git and for copying and
pasting into and from @code{tmux} paste buffers.")
(license license:gpl3+))))
+(define-public emacs-evil-nerd-commenter
+ (package
+ (name "emacs-evil-nerd-commenter")
+ (version "3.3.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/redguardtoo/evil-nerd-commenter")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0074i9lvfs5hkbf63g1xh3n7dbmkax30bppkx2cd394c7zlsvzzk"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-evil" ,emacs-evil)))
+ (home-page "https://github.com/redguardtoo/evil-nerd-commenter")
+ (synopsis "Comment and uncomment lines efficiently")
+ (description
+ "This package provides text objects and operators for comments within
+@code{evil-mode}.")
+ (license license:gpl3+)))
+
(define-public emacs-monroe
(package
(name "emacs-monroe")