summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-16 19:00:49 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-16 20:33:28 +0200
commit37d203985e2817b0962129384e8b993a1bb92de9 (patch)
treee8b627185ea86867894e27ca037b6fd7a03ef0e7 /gnu
parent0a1f520d4028fcc806cca789e0406eba229bfe16 (diff)
gnu: python-cython: Disable tests that fail on armhf.
* gnu/packages/python.scm (python-cython)[arguments]: On armhf-linux, add phase to disable two tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1d718bf228..fa5d3f5c54 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2845,6 +2845,24 @@ and is very extensible.")
(add-before 'check 'set-HOME
;; some tests require access to "$HOME/.cython"
(lambda _ (setenv "HOME" "/tmp") #t))
+
+ ;; FIXME: These tests started failing on armhf after the 0.28 update
+ ;; (commit c69d11c5930), both with an error such as this:
+ ;; compiling (cpp) and running dictcomp ...
+ ;; === C/C++ compiler error output: ===
+ ;; ‘
+ ;; dictcomp.cpp:5221: confused by earlier errors, bailing out
+ ;; See <https://hydra.gnu.org/build/2948724> for logs.
+ ,@(if (target-arm32?)
+ `((add-before 'check 'disable-failing-tests
+ (lambda _
+ (let ((disabled-tests (open-file "tests/bugs.txt" "a")))
+ (for-each (lambda (test)
+ (format disabled-tests "~a\n" test))
+ '("memslice" "dictcomp"))
+ (close-port disabled-tests)))))
+ '())
+
(replace 'check
(lambda _ (invoke "python" "runtests.py" "-vv"))))))
(home-page "http://cython.org/")