summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-22 15:56:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-22 18:24:22 +0300
commitbf3c57ff2dcaf54d1cb2767101f092c715bb5aee (patch)
tree221dfc5cca4deb409e971339645ccf94a06e01cf /gnu
parent7c5a1454144cafb37c0aa2844bc4d258bb69c413 (diff)
gnu: cssc: Use 'modify-phases'.
* gnu/packages/version-control.scm (cssc)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 705f24194a..cdaf53c33a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -898,23 +898,23 @@ large, complex patch files.")
"cssc-missing-include.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:phases (alist-cons-before
- 'check 'precheck
- (lambda _
- (begin
- (substitute* "tests/common/test-common"
- (("/bin/pwd") (which "pwd")))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'precheck
+ (lambda _
+ (begin
+ (substitute* "tests/common/test-common"
+ (("/bin/pwd") (which "pwd")))
- (substitute* "tests/prt/all-512.sh"
- (("/bin/sh") (which "sh")))
+ (substitute* "tests/prt/all-512.sh"
+ (("/bin/sh") (which "sh")))
- ;; XXX: This test has no hope of passing until there is a "nogroup"
- ;; entry (or at least some group to which the guix builder does
- ;; not belong) in the /etc/group file of the build environment.
- ;; Currently we do not have such a group. Disable this test for now.
- (substitute* "tests/Makefile"
- (("test-delta ") ""))))
- %standard-phases)))
+ ;; XXX: This test has no hope of passing until there is a "nogroup"
+ ;; entry (or at least some group to which the guix builder does
+ ;; not belong) in the /etc/group file of the build environment.
+ ;; Currently we do not have such a group. Disable this test for now.
+ (substitute* "tests/Makefile"
+ (("test-delta ") ""))))))))
;; These are needed for the tests
(native-inputs `(("git" ,git)
("cvs" ,cvs)))