summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 04:52:34 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 05:00:16 -0400
commit13f5a0dc80d02b89f46bbce21a7f8690a91a1155 (patch)
tree62618262a35133700e607e3c2b06eb7f10a2485c /gnu
parentf9b282f484e0d6039765131f4ce8dbe165b97115 (diff)
gnu: clang: Return #t from all phases.
* gnu/packages/llvm.scm (clang-from-llvm): Return #t from the 'set-glibc-file-names' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/llvm.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 2dddbc4361..cf60d2aa0d 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -191,7 +191,9 @@ compiler. In LLVM this library is called \"compiler-rt\".")
;; found.
(substitute* "lib/Driver/ToolChains.cpp"
(("@GLIBC_LIBDIR@")
- (string-append libc "/lib")))))))))
+ (string-append libc "/lib")))
+
+ #t))))))
;; Clang supports the same environment variables as GCC.
(native-search-paths