summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-27 00:55:28 -0400
committerMark H Weaver <mhw@netris.org>2018-03-27 21:35:47 -0400
commit3595e83dc5e0a8540c93340bf3039c46269b1155 (patch)
treea3ecf35894242a4cd6570365d6b1c4c68f356bf4 /gnu
parent5f55ca21051d37326afb3f8dd878340b5edd7015 (diff)
gnu: aalib: Use invoke.
* gnu/packages/video.scm (aalib)[arguments]: Use invoke in the custom configure phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index df91f943be..f148a07b72 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -153,22 +153,22 @@
(let ((out (assoc-ref outputs "out"))
(ncurses (assoc-ref inputs "ncurses")))
(setenv "CONFIG_SHELL" (which "bash"))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)
- (string-append "--build=" build)
- ;; The ancient config.guess is unable to
- ;; guess the host triplet on mips64el.
- ,@(if (string=? "mips64el-linux"
- (%current-system))
- '("--host=mips64el-unknown-linux-gnu")
- '())
- ;; The same is also true with aarch64.
- ,@(if (string=? "aarch64-linux"
- (%current-system))
- '("--host=aarch64-unknown-linux-gnu")
- '())
- (string-append "--with-ncurses="
- ncurses)))))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--build=" build)
+ ;; The ancient config.guess is unable to
+ ;; guess the host triplet on mips64el.
+ ,@(if (string=? "mips64el-linux"
+ (%current-system))
+ '("--host=mips64el-unknown-linux-gnu")
+ '())
+ ;; The same is also true with aarch64.
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '())
+ (string-append "--with-ncurses="
+ ncurses))))))))
(home-page "http://aa-project.sourceforge.net/aalib/")
(synopsis "ASCII-art library")
(description