summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-24 16:34:23 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-24 16:34:23 +0200
commit545da9fd5f6c5b55f1bdc1f735ebdf6ba71495a5 (patch)
tree974fc060059d6de971a100be4bffe1004d7fb8b5 /gnu
parent0c8e255549760e83c4acf08747047449ec952113 (diff)
gnu: python-flake8: Update to 3.6.0.
* gnu/packages/check.scm (python-hypothesis)[native-inputs]: Change PYTHON-FLAKE8 to PYTHON-FLAKE8-3.5. * gnu/packages/python.scm (python-flake8, python2-flake8): Rename to ... (python-flake8-3.5, python2-flake8-3.5): ... this. (python-flake8, python2-flake8): New public variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm3
-rw-r--r--gnu/packages/python.scm38
2 files changed, 36 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1ae6355a93..fc45c0551a 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1425,7 +1425,8 @@ normally the case.")
"1rshs1japfmwgar98yrkq4hg4z2q76hlnq7w2n3lfbjnscn1jd9b"))))
(build-system python-build-system)
(native-inputs
- `(("python-flake8" ,python-flake8)
+ `(;; FIXME: Change to python-flake8 in the next rebuild cycle.
+ ("python-flake8" ,python-flake8-3.5)
("python-pytest" ,python-pytest-bootstrap)))
(propagated-inputs
`(("python-attrs" ,python-attrs-bootstrap)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 59ef5c2ca3..a0c4669040 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5826,7 +5826,9 @@ complexity of Python source code.")
(define-public python2-pyflakes-0.8.1
(package-with-python2 python-pyflakes-0.8.1))
-(define-public python-flake8
+;; This package is used by hypothesis which has thousands of dependent packages.
+;; FIXME: Consolidate this with "python-flake8" below in the next rebuild cycle.
+(define-public python-flake8-3.5
(package
(name "python-flake8")
(version "3.5.0")
@@ -5872,17 +5874,45 @@ PEP8_PLUGIN('break_before_binary_operator'),"))
"The modular source code checker: pep8, pyflakes and co")
(description
"Flake8 is a wrapper around PyFlakes, pep8 and python-mccabe.")
- (properties `((python2-variant . ,(delay python2-flake8))))
+ (properties `((python2-variant . ,(delay python2-flake8-3.5))))
(license license:expat)))
-(define-public python2-flake8
- (let ((base (package-with-python2 (strip-python2-variant python-flake8))))
+(define-public python2-flake8-3.5
+ (let ((base (package-with-python2 (strip-python2-variant python-flake8-3.5))))
(package (inherit base)
(propagated-inputs
`(("python2-configparser" ,python2-configparser)
("python2-enum34" ,python2-enum34)
,@(package-propagated-inputs base))))))
+;; Version 3.5.0 has compatibility issues with Pyflakes 2.0, so we need
+;; this newer version. Keep it as a separate variable for now to avoid
+;; rebuilding "python-hypothesis"; this should be removed in the next
+;; rebuild cycle.
+(define-public python-flake8
+ (package
+ (inherit python-flake8-3.5)
+ (version "3.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8" version))
+ (sha256
+ (base32
+ "0w0nprx22rbvrrkbfx9v5jc5gskbm08g219l7r8wai8zfswgadba"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments python-flake8-3.5)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'delete-broken-test)
+ (delete 'fix-problem-with-pycodestyle)))))
+ (properties `((python2-variant . ,(delay python2-flake8))))))
+
+(define-public python2-flake8
+ (let ((base (package-with-python2 (strip-python2-variant python-flake8))))
+ (package (inherit base)
+ (propagated-inputs
+ (package-propagated-inputs python2-flake8-3.5)))))
+
;; python-hacking requires flake8 <2.6.0.
(define-public python-flake8-2.5
(package