summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 04:05:40 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:44:15 -0400
commit849527e5316172524aa85db4f55174819aaf6caf (patch)
treef0f32481917ef0781e36317c97060619a57b2b0a /gnu
parentc4fc86e4f8f5184f46f6c18b9c06d4dcc0e143e6 (diff)
gnu: texlive-fonts-knuth-lib: Use invoke.
* gnu/packages/tex.scm (texlive-fonts-knuth-lib)[arguments]: Use invoke in the custom build phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 29792cbb21..056039b661 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -628,13 +628,13 @@ display, and mathematical fonts in a range of styles, based on Monotype Modern
(string-append (getcwd) ":"
mf "/share/texmf-dist/metafont/base")))
(mkdir "build")
- (zero? (system* "mf" "-progname=mf"
- "-output-directory=build"
- (string-append "\\"
- "mode:=ljfour; "
- "mag:=1; "
- "batchmode; "
- "input manfnt")))))
+ (invoke "mf" "-progname=mf"
+ "-output-directory=build"
+ (string-append "\\"
+ "mode:=ljfour; "
+ "mag:=1; "
+ "batchmode; "
+ "input manfnt"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))