summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-09-21 22:45:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-09-25 21:44:29 +0200
commitaa759a51398d6245e6631d15724d1da7cafdd981 (patch)
tree9cd33973b9ee5b800db5f5fd528a24c10a1be03d /gnu
parent36ebf9728357937738b696895c146b674e35fdfc (diff)
gnu: Add python-cryptography-vectors.
* gnu/packages/python.scm (python-cryptography-vectors, python2-cryptography-vectors): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a06e265588..6fccfdef2a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5021,3 +5021,29 @@ responses, rather than doing any computation.")
(define-public python2-pretend
(package-with-python2 python-pretend))
+
+(define-public python-cryptography-vectors
+ (package
+ (name "python-cryptography-vectors")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/c/"
+ "cryptography-vectors/cryptography_vectors-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1i2chlyhlx4792di82fqzcy9wz0gnnc661bj46zr794ip4629sp4"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/pyca/cryptography")
+ (synopsis "Test vectors for the cryptography package.")
+ (description
+ "This package contains test vectors for the cryptography package.")
+ ;; Distributed under either BSD-3 or ASL2.0
+ (license (list bsd-3 asl2.0))))
+
+(define-public python2-cryptography-vectors
+ (package-with-python2 python-cryptography-vectors))