summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-02-23 11:23:49 +0100
committerAndreas Enge <andreas@enge.fr>2016-02-23 11:53:03 +0100
commit5a179844e70fb41e9747f7ba0e723184a52e757d (patch)
treedd15787d0ff68a479e5753e63df941182008eca9 /gnu
parent8758efe0b01a2b3710d81c9270ddea88b1d52e2e (diff)
gnu: Add xfce4-xkb-plugin.
* gnu/packages/xfce.scm (xfce4-xkb-plugin): New variable. (xfce)[propagated-inputs]: Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xfce.scm42
1 files changed, 41 insertions, 1 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index e213fb6067..7fab65043b 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -387,6 +388,44 @@ to an auto mixer tool like pavucontrol. It can optionally handle multimedia
keys for controlling the audio volume.")
(license gpl2+)))
+(define-public xfce4-xkb-plugin
+ (package
+ (name "xfce4-xkb-plugin")
+ (version "0.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ name "/" (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "10g65j5ia389ahhn3b9hr52ghpp0817fk0m60rfrv4wrzqrjxzk1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("garcon" ,garcon)
+ ("librsvg" ,librsvg)
+ ("libwnck" ,libwnck-1)
+ ("libx11" ,libx11)
+ ("libxfce4ui" ,libxfce4ui)
+ ("libxklavier" ,libxklavier)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page "http://git.xfce.org/panel-plugins/xfce4-xkb-plugin/")
+ (synopsis "XKB layout switching panel plug-in for Xfce")
+ (description
+ "Xfce XKB plugin makes it possible to set up and use multiple
+keyboard layouts.
+
+One can choose the keyboard model, what key combination to
+use to switch between the layouts, the actual keyboard layouts,
+the way in which the current layout is being displayed (country
+flag image or text) and the layout policy, which is whether to
+store the layout globally (for all windows), per application or
+per window.")
+ (license bsd-2)))
+
(define-public xfce4-appfinder
(package
(name "xfce4-appfinder")
@@ -695,7 +734,8 @@ on your desktop.")
;; Panel plugins.
("xfce4-battery-plugin" ,xfce4-battery-plugin)
("xfce4-clipman-plugin" ,xfce4-clipman-plugin)
- ("xfce4-pulseaudio-plugin" ,xfce4-pulseaudio-plugin)))
+ ("xfce4-pulseaudio-plugin" ,xfce4-pulseaudio-plugin)
+ ("xfce4-xkb-plugin" ,xfce4-xkb-plugin)))
(home-page "http://www.xfce.org/")
(synopsis "Desktop environment (meta-package)")
(description