summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-02-22 00:29:54 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-22 00:36:24 +0100
commit95001d4b4677b64f26a4bf202a77267830bb7039 (patch)
tree325e3d78611aee8e2ec0b8f39fca268e39215742 /gnu
parent49e0ca90bcccf01eca34b1e781b70b1560915c57 (diff)
download: Add 'url-fetch/tarbomb'.
Suggested by Federico Beffa. Fixes <http://bugs.gnu.org/22676>. Reported by Danny Milosavljevic <dannym@scratchpost.org>. * gnu/packages/engineering.scm (broken-tarball-fetch): Remove. (fastcap)[source](method): Use URL-FETCH/TARBOMB instead. * gnu/packages/scheme.scm (broken-tarball-fetch): Remove. (scmutils)[source](method): Use URL-FETCH/TARBOMB instead. * guix/download.scm (url-fetch/tarbomb): New procedure, renamed from 'broken-tarball-fetch'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/engineering.scm21
-rw-r--r--gnu/packages/scheme.scm8
2 files changed, 2 insertions, 27 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 204ea9dc02..9a36ffbb31 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -203,31 +203,12 @@ and design rule checking. It also includes an autorouter and a trace
optimizer; and it can produce photorealistic and design review images.")
(license license:gpl2+)))
-(define* (broken-tarball-fetch url hash-algo hash
- #:optional name
- #:key (system (%current-system))
- (guile (default-guile)))
- (mlet %store-monad ((drv (url-fetch url hash-algo hash
- (string-append "tarbomb-" name)
- #:system system
- #:guile guile)))
- ;; Take the tar bomb, and simply unpack it as a directory.
- (gexp->derivation name
- #~(begin
- (mkdir #$output)
- (setenv "PATH"
- (string-append #$gzip "/bin"))
- (chdir #$output)
- (zero? (system* (string-append #$tar "/bin/tar")
- "xf" #$drv))))))
-
-
(define-public fastcap
(package
(name "fastcap")
(version "2.0-18Sep92")
(source (origin
- (method broken-tarball-fetch)
+ (method url-fetch/tarbomb)
(file-name (string-append name "-" version ".tar.gz"))
(uri (string-append "http://www.rle.mit.edu/cpg/codes/"
name "-" version ".tgz"))
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 352b66c59b..00b573fc0b 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -526,12 +526,6 @@ an isolated heap allowing multiple VMs to run simultaneously in different OS
threads.")
(license bsd-3)))
-;; FIXME: This function is temporarily in the engineering module and not
-;; exported. It will be moved to an utility module for general use. Once
-;; this is done, we should remove this definition.
-(define broken-tarball-fetch
- (@@ (gnu packages engineering) broken-tarball-fetch))
-
(define-public scmutils
(let ()
(define (system-suffix)
@@ -546,7 +540,7 @@ threads.")
(version "20140302")
(source
(origin
- (method broken-tarball-fetch)
+ (method url-fetch/tarbomb)
(modules '((guix build utils)))
(snippet
;; Remove binary code