summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-02-13 00:08:22 -0500
committerDavid Thompson <dthompson2@worcester.edu>2016-02-23 19:39:56 -0500
commitdd90ed892a7dbe13a214b2d7ebf321b866211374 (patch)
tree681fa2a0fa530ba960680d7e555ecfb12f3384b8 /gnu
parentf2d8faff040986e498575de889a22d16aa1037e5 (diff)
gnu: guile-next: Set correct native search paths.
* gnu/packages/guile.scm (guile-next): Use the "2.2" directory for the load paths.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 75585649ed..2c83f56f40 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -211,7 +211,15 @@ without requiring the source code to be rewritten.")
;; times (almost 3 hours on a 4-core Intel i5).
(snippet '(for-each delete-file
(find-files "prebuilt" "\\.go$")))))
- (synopsis "Snapshot of what will become version 2.2 of GNU Guile")))
+ (synopsis "Snapshot of what will become version 2.2 of GNU Guile")
+ (native-search-paths
+ (list (search-path-specification
+ (variable "GUILE_LOAD_PATH")
+ (files '("share/guile/site/2.2")))
+ (search-path-specification
+ (variable "GUILE_LOAD_COMPILED_PATH")
+ (files '("lib/guile/2.2/ccache"
+ "share/guile/site/2.2")))))))
(define-public guile-for-guile-emacs
(package (inherit guile-next)