summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-01-28 09:50:31 -0500
committerMark H Weaver <mhw@netris.org>2016-02-04 00:15:21 -0500
commit19f339526fb154d0e29d693a4d968cd003174835 (patch)
tree02757e176701aa97b80eddaff4ff2564e73bbb1c /gnu
parentbdbb7c1852841cc87762d86ffccad740bbfb879f (diff)
gnu: openssl: Update to 1.0.2f [fixes CVE-2015-3197 and CVE-2016-0701].
* gnu/packages/tls.scm (openssl): Update to 1.0.2f. [arguments]: Remove the 'fix-broken-symlinks' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tls.scm25
1 files changed, 2 insertions, 23 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 046fbb6ca8..d70c92b71d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -180,7 +180,7 @@ required structures.")
(define-public openssl
(package
(name "openssl")
- (version "1.0.2e")
+ (version "1.0.2f")
(source (origin
(method url-fetch)
(uri (list (string-append "ftp://ftp.openssl.org/source/"
@@ -190,7 +190,7 @@ required structures.")
"/" name "-" version ".tar.gz")))
(sha256
(base32
- "1zqb1rff1wikc62a7vj5qxd1k191m8qif5d05mwdxz2wnzywlg72"))
+ "171fkdg9v6j29d962nh6kb79kfm8kkhy7n9makw39d7jvvj4wawk"))
(patches (map search-patch
'("openssl-runpath.patch"
"openssl-c-rehash.patch")))))
@@ -246,27 +246,6 @@ required structures.")
(find-files (string-append out "/lib")
"\\.so"))
#t)))
- (add-after
- 'unpack 'fix-broken-symlinks
- (lambda _
- ;; Repair the broken symlinks in the openssl-1.0.2e tarball.
- (let* ((link-prefix "openssl-1.0.2e/")
- (link-prefix-length (string-length link-prefix))
- (broken-links
- (find-files "." (lambda (file stat)
- (and (eq? 'symlink (stat:type stat))
- (string-prefix? link-prefix
- (readlink file)))))))
- (when (null? broken-links)
- (error "The 'fix-broken-symlinks' phase is obsolete; remove it"))
- (for-each (lambda (file)
- (let* ((old-target (readlink file))
- (new-target (string-drop old-target
- link-prefix-length)))
- (delete-file file)
- (symlink new-target file)))
- broken-links)
- #t)))
(add-before
'patch-source-shebangs 'patch-tests
(lambda* (#:key inputs native-inputs #:allow-other-keys)