summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 22:01:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:33 +0100
commit3b5378a87fd067dca07b35163e85056044d61cdf (patch)
treede50cf3ee073ddaa07a88e22f23cd12461220204 /gnu
parent8aed0895f1ddafd0333a15a8473ff5e1fe0751f8 (diff)
gnu: python-hypothesis: Update to 5.1.5.
* gnu/packages/check.scm (python-hypothesis): Update to 5.1.5. [native-inputs]: Remove. [arguments]: New field. [propagated-inputs]: Remove PYTHON-COVERAGE. Add PYTHON-SORTEDCONTAINERS. (python2-hypothesis): Update to 4.57.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index a8d679cc83..684721c6f2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1612,20 +1612,20 @@ instantly.")
(define-public python-hypothesis
(package
(name "python-hypothesis")
- (version "4.18.3")
+ (version "5.1.5")
(source (origin
(method url-fetch)
(uri (pypi-uri "hypothesis" version))
(sha256
(base32
- "0a35nwqyjnm4cphi43xracqpkws0ip61mndvqb1iqq7gkva83lb1"))))
+ "1ady8cjwpwsicpkhpjd6qwnipjr1lf488sv23psksbxsbgffg7sz"))))
(build-system python-build-system)
- (native-inputs
- `(("python-flake8" ,python-flake8)
- ("python-pytest" ,python-pytest-bootstrap)))
+ (arguments
+ ;; XXX: Tests are not distributed with the PyPI archive.
+ '(#:tests? #f))
(propagated-inputs
`(("python-attrs" ,python-attrs-bootstrap)
- ("python-coverage" ,python-coverage)))
+ ("python-sortedcontainers" ,python-sortedcontainers)))
(synopsis "Library for property based testing")
(description "Hypothesis is a library for testing your Python code against a
much larger range of examples than you would ever want to write by hand. It’s
@@ -1635,10 +1635,18 @@ seamlessly into your existing Python unit testing work flow.")
(license license:mpl2.0)
(properties `((python2-variant . ,(delay python2-hypothesis))))))
+;; This is the last version of Hypothesis that supports Python 2.
(define-public python2-hypothesis
(let ((hypothesis (package-with-python2
(strip-python2-variant python-hypothesis))))
(package (inherit hypothesis)
+ (version "4.57.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hypothesis" version))
+ (sha256
+ (base32
+ "183gpxbfcdhdqzlahkji5a71n6lmvgqsbkcb0ihqad51n2j6jhrw"))))
(propagated-inputs
`(("python2-enum34" ,python2-enum34)
,@(package-propagated-inputs hypothesis))))))