summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 09:33:38 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commitcd49454b7b6ec56f2ada0f818a4cdfef95431f24 (patch)
tree6dba3b658d3415c424e176d0c06652abd8a014cf /gnu
parent070ab0588c163151727c6de272c8b9cdf5827469 (diff)
gnu: Add python-fixtures.
* gnu/packages/python.scm (python-fixtures, python2-fixtures): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 914330edcf..72ca7e312a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1268,6 +1268,34 @@ protocol.")
(define-public python2-subunit
(package-with-python2 python-subunit))
+(define-public python-fixtures
+ (package
+ (name "python-fixtures")
+ (version "0.3.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/f/fixtures/fixtures-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0x9r2gwilcig5g54k60bxzg96zabizq1855lrprlb4zckalp9asc"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ '(#:tests? #f)) ; no setup.py test command
+ (home-page "https://launchpad.net/python-fixtures")
+ (synopsis "Python test fixture library")
+ (description
+ "Fixtures provides a way to create reusable state, useful when writing
+Python tests.")
+ (license (list bsd-3 asl2.0)))) ; at user's option
+
+(define-public python2-fixtures
+ (package-with-python2 python-fixtures))
+
(define-public behave
(package
(name "behave")