summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-03-10 00:26:23 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-10 00:26:23 +0100
commit0bd40ca9a9dabb47f9af1884768ffac3c07fc9e5 (patch)
treee87c81eaa14be91b2484c0e7a2dc3f521d935f0a /gnu
parent9aac443dc9697520fbad3619fd0172028805114c (diff)
gnu: libxslt: Really allow cross-compilation.
Commit af916f3f8b5e1191cdcc95dded1e376f51ad9e9b led './configure' to attempt to run a non-native 'python' binary, which would fail unless transparent binfmt_misc QEMU emulation is set up. * gnu/packages/xml.scm (libxslt)[arguments]: Replace #:configure-flags with "--disable-python" when cross-compiling.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index a132f58097..1841cb3bda 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -353,13 +353,9 @@ formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.")
#:configure-flags
(if (%current-target-system)
;; 'configure.ac' uses 'AM_PATH_PYTHON', which looks for
- ;; 'python' in $PATH, even though it's only used in the shebang
- ;; of examples. Thus, when cross-compiling, set 'PYTHON' so
- ;; that 'configure' doesn't search $PATH.
- #~(list (string-append "PYTHON="
- #$(this-package-input
- "python-minimal-wrapper")
- "/bin/python"))
+ ;; 'python' in $PATH and tries to run it. Skip all that when
+ ;; cross-compiling.
+ #~'("--without-python")
#~'())))
(home-page "http://xmlsoft.org/XSLT/index.html")
(synopsis "C library for applying XSLT stylesheets to XML documents")