summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-11-06 12:06:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-11-13 15:05:26 +0100
commit17978740e52cba864ec96a3a64cc79995f624ebb (patch)
tree23a81ad87c141d31cb004b9be2771218a431f850 /gnu
parentf95519432175d7a9061152132f4a7387e0e513a9 (diff)
gnu: Add r-baynorm.
* gnu/packages/bioconductor.scm (r-baynorm): New variable. Change-Id: I83e82d3d0362874918f423ab01f038c74f3eb265
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 80de46ac2a..e70a528b04 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -22828,6 +22828,45 @@ resolution of the low-dimensional representation into \"sub-spots\", for which
features such as gene expression or cell type composition can be imputed.")
(license license:expat)))
+(define-public r-baynorm
+ (package
+ (name "r-baynorm")
+ (version "1.20.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "bayNorm" version))
+ (sha256
+ (base32 "01lv4w1x43x3f9sdrqikhsr1gdvkgqzrgcd9wnjj76qsljn57ifq"))))
+ (properties `((upstream-name . "bayNorm")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-bb
+ r-biocparallel
+ r-dosnow
+ r-fitdistrplus
+ r-foreach
+ r-iterators
+ r-locfit
+ r-mass
+ r-matrix
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppprogress
+ r-singlecellexperiment
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/WT215/bayNorm")
+ (synopsis "Single-cell RNA sequencing data normalization")
+ (description
+ "The bayNorm package is used for normalizing single-cell RNA-seq data.
+The main function is @code{bayNorm}, which is a wrapper function for gene
+specific prior parameter estimation and normalization. The input is a matrix
+of scRNA-seq data with rows different genes and coloums different cells. The
+output is either point estimates from posterior (2D array) or samples from
+posterior (3D array).")
+ (license license:gpl2+)))
+
(define-public r-biocthis
(package
(name "r-biocthis")