summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-24 14:09:01 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:08:12 +0100
commit1915c363744fbfc90c6eddcf70de89addaf62644 (patch)
tree94f4e44970a1d4cc69bf9b068be5872199dcc09f /gnu
parent76997a0ddb2d7dde8d390470f8d28f2ea3b7d6d1 (diff)
gnu: Remove ocaml4.07-utop.
* gnu/packages/ocaml.scm (ocaml4.07-utop): Remove variable. (ocaml-utop)[properties]: Remove variant. Change-Id: I5307736534705f79e681462d07cce61cfd08699c
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 0 insertions, 23 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index dd52189811..f320e7f760 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5523,7 +5523,6 @@ instead of bindings to a C library.")
ocaml-lwt-react
ocaml-react
ocaml-zed))
- (properties `((ocaml4.07-variant . ,(delay ocaml4.07-utop))))
(home-page "https://github.com/ocaml-community/utop")
(synopsis "Improved interface to the OCaml toplevel")
(description "UTop is an improved toplevel for OCaml. It can run in a
@@ -5531,28 +5530,6 @@ terminal or in Emacs. It supports line editing, history, real-time and context
sensitive completion, colors, and more.")
(license license:bsd-3)))
-(define-public ocaml4.07-utop
- (package-with-ocaml4.07
- (package
- (inherit ocaml-utop)
- (version "2.4.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ocaml-community/utop")
- (commit version)))
- (file-name (git-file-name "ocaml4.07-utop" version))
- (sha256
- (base32 "1bl4943qpi3qy152dbdm5glhx19zsiylmn4rcxi8l66g58hikyjp"))))
- (propagated-inputs
- `(("ocaml-lambda-term" ,ocaml-lambda-term)
- ("ocaml-lwt" ,ocaml-lwt)
- ("ocaml-react" ,ocaml-react)
- ("ocaml-camomile" ,ocaml-camomile)
- ("ocaml-zed" ,ocaml-zed)))
- (properties '()))))
-
(define-public ocaml-ansiterminal
(package
(name "ocaml-ansiterminal")