summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-04-06 11:40:40 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 21:39:12 +0100
commit24bfbe13a808b57636a28df56c59ea46d1bc8b18 (patch)
treeea1de19dcb38cf7215288f550d17310386e7f3bc /gnu
parent93b19868e68155c023c41812c710b5dbc1023dcb (diff)
gnu: Add go-github-com-multiformats-go-base36.
* gnu/packages/golang-xyz.scm (go-github-com-multiformats-go-base36): New variable. Change-Id: I27c5540fddae55ae9ce12a205d6f7f7c9a01569b Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 6e634212c0..9b3c387fd5 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2147,6 +2147,29 @@ command line flags, config files, and default struct values.")
"@code{base32} encoding package from Go with @code{NoPadding} option")
(license license:bsd-3)))
+(define-public go-github-com-multiformats-go-base36
+ (package
+ (name "go-github-com-multiformats-go-base36")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/multiformats/go-base36")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wfhsmxkvm97pglfwgiw3ad5g9vqc9nhd61i0kyvsb9lc006g8qq"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/multiformats/go-base36"))
+ (home-page "https://github.com/multiformats/go-base36")
+ (synopsis "Optimized @code{base36} codec for Go")
+ (description
+ "Optimized codec for @code{[]byte} <=> @code{base36} string conversion.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public go-github-com-multiformats-go-varint
(package
(name "go-github-com-multiformats-go-varint")