summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 00:20:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:37 +0200
commit4270d94ee36775b88765bc322af7f7c1a514f125 (patch)
tree7cae1a1098888bf0a4417e65dca78cf59bac99ed /gnu
parent9828271f046e5909c66af11e09c96215e426b4aa (diff)
gnu: texlive-latex-hanging -> texlive-hanging.
* gnu/packages/tex.scm (texlive-hanging): New variable. (texlive-latex-hanging): Deprecate variable. * gnu/packages/maths.scm (hypre): Use new name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/tex.scm21
2 files changed, 15 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 14583f7b45..497a8f7ba7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5804,7 +5804,7 @@ set.")
texlive-latex-fncychap
texlive-latex-framed
texlive-latex-geometry
- texlive-latex-hanging
+ texlive-hanging
texlive-hyperref
texlive-latex-multirow
texlive-latex-natbib
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c8a7ca24e1..0818461101 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5245,14 +5245,19 @@ but non-expandable ones.")
(define-deprecated-package texlive-latex-filemod texlive-filemod)
-(define-public texlive-latex-hanging
+(define-public texlive-hanging
(package
- (inherit (simple-texlive-package
- "texlive-latex-hanging"
- '("/tex/latex/hanging/")
- (base32
- "0s86yaxyfv9zxf4svwg9s13by9vrw38apfg0hsfchsimsdd6gsbb")
- #:trivial? #t))
+ (name "texlive-hanging")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/hanging"
+ "source/latex/hanging"
+ "tex/latex/hanging/")
+ (base32
+ "1d9kr163vn9sm9p9dyppnnffdcdjlgrm7848d97s678hdb9cp962")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
(home-page "https://www.ctan.org/pkg/hanging")
(synopsis "Typeset hanging paragraphs")
(description
@@ -5261,6 +5266,8 @@ paragraphs. The package also enables typesetting with hanging punctuation,
by making punctuation characters active.")
(license license:lppl1.3c+)))
+(define-deprecated-package texlive-latex-hanging texlive-hanging)
+
(define-public texlive-fira
(package
(inherit (simple-texlive-package