summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-09 11:05:23 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-09 11:34:08 +0200
commit4b3a535770b19d9c17196bd6e5c9337233d9fb92 (patch)
treea489af8ef751a5308417a4283929aeb15cca74e2 /gnu
parent4dcd19d3ff143e7ef5ed1584a9ace65c348d1dfa (diff)
gnu: macs: Remove generated code.
* gnu/packages/bioinformatics.scm (macs)[source]: Add snippet to remove cython generated code. [native-inputs]: Add python-cython.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 010742b37b..06972dee51 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4475,7 +4475,19 @@ experiments.")
(file-name (git-file-name name version))
(sha256
(base32
- "1c5gxr0mk6hkd4vclf0k00wvyvzw2vrmk52c85338p7aqjwg6n15"))))
+ "1c5gxr0mk6hkd4vclf0k00wvyvzw2vrmk52c85338p7aqjwg6n15"))
+ (modules '((guix build utils)))
+ ;; Remove files generated by Cython
+ (snippet
+ '(begin
+ (for-each (lambda (file)
+ (let ((generated-file
+ (string-append (string-drop-right file 3) "c")))
+ (when (file-exists? generated-file)
+ (delete-file generated-file))))
+ (find-files "." "\\.pyx$"))
+ (delete-file "MACS2/IO/CallPeakUnitPrecompiled.c")
+ #t))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -4489,7 +4501,8 @@ experiments.")
(inputs
`(("python-numpy" ,python-numpy)))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-cython" ,python-cython)
+ ("python-pytest" ,python-pytest)))
(home-page "https://github.com/macs3-project/MACS")
(synopsis "Model based analysis for ChIP-Seq data")
(description