summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-11-06 12:06:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-11-13 15:00:00 +0100
commit4e1c6f499880e867d162dacff32c59635e675dbf (patch)
tree1f00a11a1f4e62d845eca7cf83a1d98a26b7ddc1 /gnu
parent47a419564976aff55fed898c478ee43b96ab9159 (diff)
gnu: Add r-basics.
* gnu/packages/bioconductor.scm (r-basics): New variable. Change-Id: I6f0afeeb41f667d780707af65034d5ba978f0d4a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 303a3a2450..3955f04bf1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -22622,6 +22622,56 @@ viewpoint can be visualized as a coverage plot based on a running median
approach and a multi-scale contact profile.")
(license license:lgpl3)))
+(define-public r-basics
+ (package
+ (name "r-basics")
+ (version "2.14.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BASiCS" version))
+ (sha256
+ (base32 "0kf215n151sxphc5w9h4i2xsk7lmysi4abwcpyz4slbwhpki3ac8"))))
+ (properties `((upstream-name . "BASiCS")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-assertthat
+ r-biobase
+ r-biocgenerics
+ r-biocparallel
+ r-coda
+ r-cowplot
+ r-ggextra
+ r-ggplot2
+ r-hexbin
+ r-mass
+ r-matrix
+ r-matrixstats
+ r-posterior
+ r-rcpp
+ r-rcpparmadillo
+ r-reshape2
+ r-s4vectors
+ r-scran
+ r-scuttle
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-viridis))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/catavallejos/BASiCS")
+ (synopsis "Bayesian analysis of single-cell sequencing data")
+ (description
+ "@acronym{BASiCS, Bayesian analysis of single-cell sequencing data} is an
+integrated Bayesian hierarchical model to perform statistical analyses of
+single-cell RNA sequencing datasets in the context of supervised experiments
+(where the groups of cells of interest are known a priori. BASiCS performs
+built-in data normalisation (global scaling) and technical noise quantification
+(based on spike-in genes). BASiCS provides an intuitive detection criterion
+for highly (or lowly) variable genes within a single group of cells.
+Additionally, BASiCS can compare gene expression patterns between two or more
+pre-specified groups of cells.")
+ (license license:gpl3)))
+
(define-public r-basilisk-utils
(package
(name "r-basilisk-utils")