summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-26 11:42:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-26 11:44:45 +0200
commit4ef9fbcc358a115643cfb4610230dcf335bd788a (patch)
tree57498024a7a6e3efbb6a80cff63b09bd87160e91 /gnu
parentcc79cacceec45f4d731ca95eb9fc8006ce7e7cbc (diff)
gnu: python-jupyter-client: Disable one test.
* gnu/packages/python-xyz.scm (python-jupyter-client)[arguments]: Begrudgingly disable one failing test, because there is no information on why it fails.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 44834dc2f0..937c0be717 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9636,7 +9636,12 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(when tests?
;; Some tests try to write to $HOME.
(setenv "HOME" "/tmp")
- (invoke "pytest" "-vv"))))))))
+ (invoke "pytest" "-vv"
+ "-k"
+ ;; XXX "RuntimeError: Kernel died before replying
+ ;; to kernel_info", but there's no more
+ ;; information.
+ "not test_start_parallel_process_kernels"))))))))
(native-inputs
(list python-pytest
python-pytest-asyncio