summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-11-06 12:06:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-11-13 15:03:29 +0100
commit53b4e01e2947296ed48f584bcfded865fc0f1a75 (patch)
tree78f5952fe5014d23e637f44f2eed9ef4ebecff41 /gnu
parentbf93f88c20928664d55b0039d7a5d4938cb638d8 (diff)
gnu: Add r-bayesspace.
* gnu/packages/bioconductor.scm (r-bayesspace): New variable. Change-Id: Id9c0d23e209bafea5941a1e1f968fab5f1724eab
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d27ccce6c2..80de46ac2a 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -22781,6 +22781,53 @@ variable is the knocked-down gene, while the other genes are potential
targets. It can also be used for differential expression/2-class data.")
(license license:gpl3)))
+(define-public r-bayesspace
+ (package
+ (name "r-bayesspace")
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BayesSpace" version))
+ (sha256
+ (base32 "1mqgsylnrvf197cin5zzihjv31bm2q0m5a612ncbglys6n1jd105"))))
+ (properties `((upstream-name . "BayesSpace")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-assertthat
+ r-biocfilecache
+ r-biocsingular
+ r-coda
+ r-dirichletreg
+ r-ggplot2
+ r-matrix
+ r-mclust
+ r-purrr
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppdist
+ r-rcppprogress
+ r-rcurl
+ r-rhdf5
+ r-s4vectors
+ r-scales
+ r-scater
+ r-scran
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-xgboost))
+ (native-inputs (list r-knitr))
+ (home-page "https://www.ezstatconsulting.com/BayesSpace/")
+ (synopsis "Clustering and resolution enhancement of spatial transcriptomes")
+ (description
+ "This package provides tools for clustering and enhancing the resolution
+of spatial gene expression experiments. BayesSpace clusters a low-dimensional
+representation of the gene expression matrix, incorporating a spatial prior to
+encourage neighboring spots to cluster together. The method can enhance the
+resolution of the low-dimensional representation into \"sub-spots\", for which
+features such as gene expression or cell type composition can be imputed.")
+ (license license:expat)))
+
(define-public r-biocthis
(package
(name "r-biocthis")