summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 16:22:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:51 +0200
commit70f6df6839ec8157a1c85704c5e7482448877599 (patch)
tree76de8b3b26caeea9d62ba9ef105b2f001f9675ee /gnu
parent17cdf29a9ce380a1ae9643d3d900876cb2b97f2e (diff)
gnu: texlive-latex-jknapltx -> texlive-jknapltx.
* gnu/packages/tex.scm (texlive-jknapltx): New variable. (texlive-latex-jknapltx): Deprecate variable. * gnu/packages/docbook.scm (dblatex): * gnu/packages/python-xyz.scm (python-nbconvert): Use new name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/docbook.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/tex.scm46
3 files changed, 20 insertions, 30 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 7ff920409e..b214dbc9df 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -546,7 +546,7 @@ the in DocBook SGML DTDs.")
texlive-float
texlive-footmisc
texlive-hyperref
- texlive-latex-jknapltx
+ texlive-jknapltx
texlive-listings
texlive-latex-multirow
texlive-latex-overpic
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ceee6ba98a..c0c13a3734 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15188,7 +15188,7 @@ time.")
texlive-fancyvrb
texlive-float
texlive-geometry
- texlive-latex-jknapltx
+ texlive-jknapltx
texlive-ms
texlive-latex-parskip
texlive-trimspaces
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 057a0f9883..33f2a46170 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6839,44 +6839,34 @@ styles. Support for @code{hyperref} is provided.")
(define-deprecated-package texlive-latex-listings texlive-listings)
-(define-public texlive-latex-jknapltx
+(define-public texlive-jknapltx
(package
- (name "texlive-latex-jknapltx")
+ (name "texlive-jknapltx")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/jknapltx"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0m034x72f2g07icr50gacyxfb9g1lz2rmqh4kqr1qjb421x2kds9"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/jknapltx")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/jknappen")
+ (source (texlive-origin
+ name version
+ (list "doc/latex/jknapltx/"
+ "tex/latex/jknapltx/")
+ (base32
+ "0as43yqq123cacxhvp4sbdp4ka3cyp2spmxwayqny0fh5rsk6qaq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-graphics))
+ (home-page "https://ctan.org/pkg/jknapltx")
(synopsis "Miscellaneous packages by Joerg Knappen")
(description
- "This package provides miscellaneous macros by Joerg Knappen, including:
-represent counters in greek; Maxwell's non-commutative division;
+ "This package provides miscellaneous macros by Joerg Knappen,
+including: represent counters in greek; Maxwell's non-commutative division;
@code{latin1jk}, @code{latin2jk} and @code{latin3jk}, which are
@code{inputenc} definition files that allow verbatim input in the respective
ISO Latin codes; blackboard bold fonts in maths; use of RSFS fonts in maths;
extra alignments for @code{\\parboxes}; swap Roman and Sans fonts;
transliterate semitic languages; patches to make (La)TeX formulae embeddable
in SGML; use maths minus in text as appropriate; simple Young tableaux.")
- (license license:gpl2)))
+ (license license:gpl3+)))
+
+(define-deprecated-package texlive-latex-jknapltx texlive-jknapltx)
(define-public texlive-kvoptions
(let ((template (simple-texlive-package