summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 10:57:04 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:15 +0100
commit76968f549d4828cc8e6425b0e0ff8568c9803fe3 (patch)
treeaf401b0cc60c7e81a8cac713e3f6241bec38a894 /gnu
parent553c25da8240e035d9853f167c79177385a9a4ca (diff)
gnu: Remove ocaml4.07-ppx-pipebang.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-pipebang): Remove variable. (ocaml-ppx-pipebang)[properties]: Remove variant. Change-Id: I3c74444122e43571c9922bf703701e20b7baf58f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 1 insertions, 19 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b6590509af..f8bdff934e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7211,31 +7211,13 @@ context such as function arguments.")
(build-system dune-build-system)
(arguments `(#:tests? #f)); no tests
(propagated-inputs (list ocaml-ppxlib))
- (properties `((upstream-name . "ppx_pipebang")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-pipebang))))
+ (properties `((upstream-name . "ppx_pipebang")))
(home-page "https://github.com/janestreet/ppx_pipebang")
(synopsis "Inline reverse application operators `|>` and `|!`")
(description "A ppx rewriter that inlines reverse application operators
@code{|>} and @code{|!}.")
(license license:expat)))
-(define-public ocaml4.07-ppx-pipebang
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-pipebang)
- (version "0.11.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
- (version-major+minor version)
- "/files/ppx_pipebang-v" version ".tar.gz"))
- (sha256
- (base32
- "1wrrzlb4kdvkkcmzi01fw25jar38r2jlnyn0i6pn4z0lq4gpm9m0"))))
- (propagated-inputs (list ocaml-migrate-parsetree ocaml-ppxlib))
- (properties '())
- (license license:asl2.0))))
-
(define-public ocaml-ppx-module-timer
(package
(name "ocaml-ppx-module-timer")