summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 16:47:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:54 +0200
commit87005d9aab364c462aef1b58e11dc231980de6bd (patch)
tree3ee1a359e8f29cd4148ee24a6e65886d73f8c876 /gnu
parentdaf6f34c1e3d34dd515c153782aa51701a2bba62 (diff)
gnu: texlive-latex-pbox -> texlive-pbox.
* gnu/packages/tex.scm (texlive-pbox): New variable. (texlive-latex-pbox): Deprecate variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 19 insertions, 11 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9650456b20..91b0d44e89 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7440,23 +7440,31 @@ designed class) helps alleviate this untidiness.")
(define-deprecated-package texlive-latex-parskip texlive-parskip)
-(define-public texlive-latex-pbox
+(define-public texlive-pbox
(package
- (inherit (simple-texlive-package
- "texlive-latex-pbox"
- (list "doc/latex/pbox/"
- "tex/latex/pbox/")
- (base32 "0902snjidmhjml01zcppcpp4j6pidin1sdvfi7gnbb5v86zd5f0n")
- #:trivial? #t))
+ (name "texlive-pbox")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/pbox/"
+ "source/latex/pbox/"
+ "tex/latex/pbox/")
+ (base32
+ "104x4y22msgxhnlz2x331zq7rw28v129s5ym1jqhsk685izb3hcl")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-tools))
(home-page "https://ctan.org/pkg/pbox")
- (synopsis "\\parbox with a variable width")
+ (synopsis "@code{\\parbox} with a variable width")
(description
- "@code{pbox} defines a \\pbox{<max width>}{<text>} command which adjusts
-the box width to that of the enclosed text, up to the maximum width given. The
-package also defines some associated length commands.")
+ "@code{pbox} defines a @code{\\pbox} command which adjusts the box width
+to that of the enclosed text, up to the maximum width given. The package also
+defines some associated length commands.")
(license license:gpl3+)))
+(define-deprecated-package texlive-latex-pbox texlive-pbox)
+
(define-public texlive-pdfpages
(let ((template (simple-texlive-package
"texlive-pdfpages"