summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJaeme Sifat <jaeme@runbox.com>2023-11-04 15:55:07 -0400
committerChristopher Baines <mail@cbaines.net>2023-11-05 17:57:49 +0000
commita482d3d9ba41c914de1a08ac0ef71406925b8a19 (patch)
treea9375ed47454178382462f20f16829eb7527f2f8 /gnu
parentaa98a976079101318d53b412fef6c722bb4332c9 (diff)
gnu: dunst: Update to 1.9.2.
* gnu/packages/dunst.scm (dunst): Update to 1.9.2. [arguments]: Use gexps. Change-Id: Ic13f1679074462918991a1ceba8571a46e721224 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/dunst.scm76
1 files changed, 39 insertions, 37 deletions
diff --git a/gnu/packages/dunst.scm b/gnu/packages/dunst.scm
index 4a8ff59ec9..ee389098fb 100644
--- a/gnu/packages/dunst.scm
+++ b/gnu/packages/dunst.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
(define-module (gnu packages dunst)
#:use-module (guix packages)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix utils)
@@ -41,45 +43,45 @@
(define-public dunst
(package
(name "dunst")
- (version "1.9.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dunst-project/dunst")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1nfxf2rahngxpy606yrizrz16d0pswl5sa9jfzpv7h19x6xy24vx"))))
+ (version "1.9.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dunst-project/dunst")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17zrw7jrnlyln81pxw7p4jgvl7j1w1gf488nfskhns6j6dcz90gh"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no check target
- #:make-flags (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" %output)
- (string-append "SYSCONFDIR=" %output "/etc")
- ;; Otherwise it tries to install service file
- ;; to "dbus" store directory.
- (string-append "SERVICEDIR_DBUS=" %output
- "/share/dbus-1/services")
- "dunstify")
- #:phases (modify-phases %standard-phases
- (delete 'configure))))
- (native-inputs
- (list pkg-config perl ; for pod2man
- which))
- (inputs
- (list dbus
- (librsvg-for-system) ; for svg support
- glib
- cairo
- pango
- libnotify ; for dunstify
- libx11
- libxscrnsaver
- libxinerama
- libxrandr
- libxdg-basedir
- wayland)) ; for wayland support
+ (list
+ #:tests? #f ;no check target
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target))
+ (string-append "PREFIX=" %output)
+ (string-append "SYSCONFDIR=" %output "/etc")
+ ;; Otherwise it tries to install service file
+ ;; to "dbus" store directory.
+ (string-append "SERVICEDIR_DBUS=" %output
+ "/share/dbus-1/services")
+ "dunstify")
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list pkg-config perl ;for pod2man
+ which))
+ (inputs (list dbus
+ (librsvg-for-system) ;for svg support
+ glib
+ cairo
+ pango
+ libnotify ;for dunstify
+ libx11
+ libxscrnsaver
+ libxinerama
+ libxrandr
+ libxdg-basedir
+ wayland)) ;for wayland support
(home-page "https://dunst-project.org/")
(synopsis "Customizable and lightweight notification daemon")
(description