summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-01-20 21:54:32 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-25 18:58:18 +0100
commita7557329d971a00732f17bed9075feb5b58d0b0d (patch)
tree3058537d535d7b8b2eab5eda8bb1f910d3c886c3 /gnu
parentd8d37b98e962cf2591d63b344834b1a037779165 (diff)
gnu: emacs-mu4e-alert: Update to 1.0-0.3c9af8c.
* gnu/packages/emacs-xyz.scm (emacs-mu4e-alert): Update to 1.0-0.3c9af8c. [source]: Switch to maintained fork. [propagated-inputs]: Reorder alphabetically. [home-page]: Ditto. [synopsis]: Update to match main uses of package. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Original repository is no longer maintained and MELPA has switched to an active fork, required for compatibility with recent versions of mu4e. See <https://github.com/melpa/melpa/pull/7927>.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm46
1 files changed, 24 insertions, 22 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 68c8d84847..c76439091e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -120,6 +120,7 @@
;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -15516,28 +15517,29 @@ a (typically) noncontiguous set of text.")
(license license:gpl3+)))
(define-public emacs-mu4e-alert
- (package
- (name "emacs-mu4e-alert")
- (version "1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/iqbalansari/mu4e-alert")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1nvsfbfsma59ilf7c3vjngnmx3aapwvvvaafdy5szm5r6lkicqvg"))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-alert emacs-s emacs-ht mu))
- (home-page "https://github.com/iqbalansari/mu4e-alert")
- (synopsis "Desktop notification for mu4e")
- (description
- "This package provides desktop notifications for mu4e.
-Additionally it can display the number of unread emails in the
-mode-line.")
- (license license:gpl3+)))
+ (let ((commit "3c9af8c7994df0a1a4f0703552ea3beffb485ace")
+ (revision "0"))
+ (package
+ (name "emacs-mu4e-alert")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xzz53/mu4e-alert")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13li5pqqkzj7dwgpnngnk1ff46i100qw9xknlimpy2vf2k5yqv3y"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-alert emacs-ht emacs-s mu))
+ (home-page "https://github.com/xzz53/mu4e-alert")
+ (synopsis "Desktop notifications and mode line display for mu4e")
+ (description
+ "This package provides desktop notifications for mu4e.
+Additionally it can display the number of unread emails in the mode line.")
+ (license license:gpl3+))))
(define-public emacs-mu4e-jump-to-list
(let ((commit "358bba003543b49ffa266e503e54aebd0ebe614b")