summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJim Newsome <jnewsome@torproject.org>2022-08-09 09:38:40 -0500
committerMathieu Othacehe <othacehe@gnu.org>2022-08-15 11:20:28 +0200
commitae549cf48f14efc61a5bf7cec6203708dbb55068 (patch)
treef21ebf84cbe759d6460ebd10f12280ffbf7328db /gnu
parent6b2d29a6f53a9fe0be72953611f9f910b871d9af (diff)
gnu: torsocks: Update to 2.4.0.
* gnu/packages/tor.scm (torsocks): Update to 2.4.0. [native-inputs]: Add autoconf, automake, libtool because torsocks releases no longer pre-run autogen.sh. [synopsis, description]: Clarify that applications do not need to be socks-aware to be used with torsocks. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tor.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 8648447ee2..d71374542b 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 André Batista <nandre@riseup.net>
;;; Copyright © 2021-2022 Danial Behzadi <dani.behzi@ubuntu.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jim Newsome <jnewsome@torproject.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -160,17 +161,19 @@ This package only provides a client to the Tor Network.")))
(define-public torsocks
(package
(name "torsocks")
- (version "2.3.0")
+ (version "2.4.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://people.torproject.org/~dgoulet/"
- "torsocks/torsocks-" version ".tar.xz"))
+ (uri (string-append "https://gitlab.torproject.org/tpo/core/torsocks/-/archive/v"
+ version "/torsocks-v" version ".tar.bz2"))
(sha256
(base32
- "08inrkap29gikb6sdmb58z43hw4abwrfw7ny40c4xzdkss0vkwdr"))))
+ "1a7k3njdhp7dz603knhisna1zvxw35j3g213p6dvczv9bcjy7cjl"))))
(build-system gnu-build-system)
(inputs
(list libcap))
+ (native-inputs
+ (list autoconf automake libtool))
(arguments
`(#:phases (modify-phases %standard-phases
(add-after 'build 'absolutize
@@ -180,11 +183,11 @@ This package only provides a client to the Tor Network.")))
(string-append "getcap=" (which "getcap") "\n")))
#t)))))
(home-page "https://www.torproject.org/")
- (synopsis "Use socks-friendly applications with Tor")
+ (synopsis "Transparently route an application's traffic through Tor.")
(description
- "Torsocks allows you to use most socks-friendly applications in a safe
-way with Tor. It ensures that DNS requests are handled safely and explicitly
-rejects UDP traffic from the application you're using.")
+ "Torsocks allows you to use most applications in a safe way with Tor. It
+ensures that DNS requests are handled safely and explicitly rejects UDP
+traffic from the application you're using.")
;; All the files explicitly say "version 2 only".
(license license:gpl2)))