summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2023-03-13 22:53:02 +0900
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-02 22:28:53 +0200
commitb2d70729bb7c535e2e79df19b71a72a180386456 (patch)
tree4f391a20ff91210bdc538022e0c8f8af88716fad /gnu
parent9aac86ff32921446c93f6f2823e31bd046c981b8 (diff)
gnu: Add ruby-unicode-plot.
* gnu/packages/plotutils.scm (ruby-unicode-plot): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/plotutils.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 963587ca2e..34f507e825 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016-2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system ruby)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
@@ -50,7 +52,9 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages statistics)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tex)
#:use-module (gnu packages web)
@@ -427,3 +431,28 @@ LaTeX does for scientific text.")
;; noted otherwise, are released under version 3 (or later) of the GNU
;; Lesser General Public License"
(license license:lgpl3+)))
+
+(define-public ruby-unicode-plot
+ (package
+ (name "ruby-unicode-plot")
+ (version "0.0.5")
+ ;; Source at RubyGems.org doesn't have test fixtures.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/red-data-tools/unicode_plot.rb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g67brnb7zp1xx9cp1x7bmyxwnvi2i8gplw7p1j7cppzin4kr1vj"))))
+ (build-system ruby-build-system)
+ (native-inputs (list bundler ruby-rake ruby-test-unit ruby-yard))
+ (propagated-inputs (list ruby-enumerable-statistics))
+ (synopsis "Library to plot your data by Unicode characters")
+ (description "UnicodePlot provides the feature to make charts with Unicode
+characters. Supported charts are: barplot, boxplot, densityplot,
+histogram, lineplot, and scatterplot.")
+ (home-page "https://github.com/red-data-tools/unicode_plot.rb")
+ (license license:expat)))