summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2022-08-14 15:05:49 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-08-14 15:14:28 -0700
commitb30614b28cdc4eb893eeea4523109769f913499e (patch)
tree2f396500c68751f383ee4b85ac44f25f1aec6448 /gnu
parent51f978f4ad796e8e44a0a19ee5ab468b4b8a3958 (diff)
gnu: itpp: Remove non-deterministic log file.
* gnu/packages/maths.scm (itpp)[arguments]: Add 'delete-formulas-log phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c79058ab42..b82987e7a2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1824,6 +1824,12 @@ the resulting text.")
(arguments `(#:tests? #f ; Tests require googletest *sources*
#:phases
(modify-phases %standard-phases
+ (add-after 'install 'delete-formulas-log
+ ;; Contains date and timing information which is unreproducible,
+ ;; and should not be needed when using the package
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (delete-file (string-append out "/share/doc/itpp/html/_formulas.log")))))
(add-after 'unpack 'set-man-page-date
(lambda _
(substitute* "itpp-config.1.cmake.in"