summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 00:24:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:38 +0200
commitb42e997e85967f4da18822c221d4dd176a728b63 (patch)
tree38ee19ecdd4f159d1cce469d36a2fb4831f577a5 /gnu
parentd8418675b03e8fa3c4e2d5926efb3da6c3769bb3 (diff)
gnu: texlive-latex-natbib -> texlive-natbib.
* gnu/packages/tex.scm (texlive-natbib): New variable. (texlive-latex-natbib): Deprecate variable. (texlive-apacite): * gnu/packages/bioinformatics.scm (discrover): * gnu/packages/maths.scm (hypre): Use new name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/tex.scm35
3 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3ebfdcc385..eab2b24ab1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4772,7 +4772,7 @@ data and settings.")
texlive-latex-examplep
texlive-hyperref
texlive-ms
- texlive-latex-natbib
+ texlive-natbib
texlive-bibtex ;style files used by natbib
texlive-pgf ;tikz
texlive-latex-verbatimbox))
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 497a8f7ba7..052e9c791d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5807,7 +5807,7 @@ set.")
texlive-hanging
texlive-hyperref
texlive-latex-multirow
- texlive-latex-natbib
+ texlive-natbib
texlive-latex-needspace
texlive-latex-newunicodechar
texlive-latex-parskip
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 91cf368cc7..56c2ceafc9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5351,30 +5351,31 @@ between various classes of Unix systems.")
(define-deprecated-package texlive-latex-ifplatform texlive-ifplatform)
-(define-public texlive-latex-natbib
+(define-public texlive-natbib
(package
- (name "texlive-latex-natbib")
+ (name "texlive-natbib")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "natbib"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0aqliq0nwblxyrzhwhv77pnmk7qh2y3prgq7z7qhwcbgz5kisld7"))))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/natbib/" "doc/latex/natbib/"
+ "source/latex/natbib/" "tex/latex/natbib/")
+ (base32
+ "17hyba6v24wrbjvakgjxkndjb418mmi2wmnhrm7zmfwb0bvy6f2j")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/natbib"))
- (home-page "https://www.ctan.org/pkg/natbib")
+ (home-page "https://ctan.org/pkg/natbib")
(synopsis "Flexible bibliography support")
(description
- "This bundle provides a package that implements both author-year and
+ "The bundle provides a package that implements both author-year and
numbered references, as well as much detailed of support for other
-bibliography use. Also provided are versions of the standard BibTeX styles
-that are compatible with @code{natbib}: @code{plainnat}, @code{unsrtnat},
-@code{abbrnat}. The bibliography styles produced by @code{custom-bib} are
-designed from the start to be compatible with @code{natbib}.")
+bibliography use. Also Provided are versions of the standard BibTeX styles
+that are compatible with natbib--plainnat, unsrtnat, abbrnat. The
+bibliography styles produced by custom-bib are designed from the start to be
+compatible with @code{natbib}.")
(license license:lppl)))
+(define-deprecated-package texlive-latex-natbib texlive-natbib)
+
(define-public texlive-latex-newfloat
(package
(inherit (simple-texlive-package
@@ -11914,7 +11915,7 @@ maintained).")
(base32
"0bcfpcmflhvxwzmdj8dgf43mzaywx2asahp52nqn3wwvq64bqym6")
#:trivial? #t))
- (propagated-inputs (list texlive-latex-natbib
+ (propagated-inputs (list texlive-natbib
texlive-tools))
(home-page "https://www.ctan.org/pkg/apacite")
(synopsis "Citation style following the rules of the APA")