summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-11-14 13:02:45 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-11-14 13:21:40 +0100
commitb5d419b4ab6863a0059fbabb68eaa90e61d0f1af (patch)
tree6370b8f8a9acfc4138f51562c2d92179aaf306ea /gnu
parenta572e55ea543e393260c952d3d2d4cb059115fa9 (diff)
gnu: emacs-flycheck-grammalecte: Improve package style.
* gnu/packages/emacs-xyz.scm (emacs-flycheck-grammalecte)[arguments]Use G-expressions. <#:exclude>: Remove non-existing excluded file. <#:emacs>: Use EMACS-NO-X. <#:phases>: Use G-expressions. Change-Id: Ic5a3c5e3f5271e75cd369cdd40ce210d7c2b859b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm60
1 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4fd472767f..9399377c29 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8360,36 +8360,36 @@ for Flow files.")
(base32 "0vsf0zsqqfaarwq1k34kg5sqgywzr6dklqv093imm9q6ys18p8c4"))))
(build-system emacs-build-system)
(arguments
- `(#:include (cons "\\.py$" %default-include)
- #:exclude '("^test-profile.el$")
- #:emacs ,emacs ;need libxml support
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'specify-python-location
- ;; Hard-code python3 executable location in the library.
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((python3 (search-input-file inputs "/bin/python3")))
- (substitute* '("flycheck-grammalecte.el" "grammalecte.el")
- (("\"python3") (string-append "\"" python3)))
- (substitute* '("conjugueur.py" "flycheck_grammalecte.py")
- (("/usr/bin/env python3?") python3)))))
- (add-after 'unpack 'specify-grammalecte-location
- ;; Use our own Grammalecte.
- (lambda* (#:key inputs #:allow-other-keys)
- (make-file-writable "grammalecte.el")
- (emacs-substitute-variables "grammalecte.el"
- ("grammalecte-python-package-directory"
- (search-input-directory
- inputs
- (string-append "lib/python"
- ,(version-major+minor (package-version python))
- "/site-packages/grammalecte"))))))
- (add-after 'unpack 'do-not-phone-home
- ;; Do not check for Grammalecte updates, ever.
- (lambda _
- (make-file-writable "grammalecte.el")
- (emacs-substitute-variables "grammalecte.el"
- ("grammalecte-check-upstream-version-delay" 0)))))))
+ (list
+ #:include #~(cons "\\.py$" %default-include)
+ #:emacs emacs-no-x ;need libxml support
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'specify-python-location
+ ;; Hard-code python3 executable location in the library.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((python3 (search-input-file inputs "/bin/python3")))
+ (substitute* '("flycheck-grammalecte.el" "grammalecte.el")
+ (("\"python3") (string-append "\"" python3)))
+ (substitute* '("conjugueur.py" "flycheck_grammalecte.py")
+ (("/usr/bin/env python3?") python3)))))
+ (add-after 'unpack 'specify-grammalecte-location
+ ;; Use our own Grammalecte.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "grammalecte.el")
+ (emacs-substitute-variables "grammalecte.el"
+ ("grammalecte-python-package-directory"
+ (search-input-directory
+ inputs
+ (string-append "lib/python"
+ #$(version-major+minor (package-version python))
+ "/site-packages/grammalecte"))))))
+ (add-after 'unpack 'do-not-phone-home
+ ;; Do not check for Grammalecte updates, ever.
+ (lambda _
+ (make-file-writable "grammalecte.el")
+ (emacs-substitute-variables "grammalecte.el"
+ ("grammalecte-check-upstream-version-delay" 0)))))))
(inputs
(list grammalecte python))
(propagated-inputs