summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-09 10:34:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-09 10:43:03 +0300
commitbc702a07c5dae6f04d70146a2c6bafffe9ddd865 (patch)
treeaf11bc68dff6c3e32501ccde47024281d0c6467f /gnu
parent8a3b574b9c7ae6806247aefb22e6597c0ea4a8b7 (diff)
gnu: rest-next: Don't set #:tests? to #:true.
* gnu/packages/gnome.scm (rest-next)[arguments]: Rewrite to strip #:tests? argument from the inherited package.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4d680e4a85..d8a5ba6f75 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4955,8 +4955,10 @@ libxml to ease remote use of the RESTful API.")
(base32
"1qy2291d2vprdbbxmf0sa98izk09nl3znzzv7lckwf6f1v0sarlj"))))
(build-system meson-build-system)
- (arguments (substitute-keyword-arguments (package-arguments rest)
- ((#:tests? _ #f) #t)
+ (arguments (substitute-keyword-arguments
+ (strip-keyword-arguments
+ '(#:tests?)
+ (package-arguments rest))
((#:configure-flags _)
;; Do not build the optional 'librest-demo' program as it
;; depends on gtksourceview and libadwaita and thus,