summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-09 11:49:29 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-10 01:31:42 +0200
commitc823b958256ba1db6cf896400fae218e4261266e (patch)
treeeb394cec290465d5dc6771989b00869afbeccc72 /gnu
parentdf49fe2a13d933c640e3189413c5adfced1103c5 (diff)
gnu: coreutils: Patch broken Gnulib tests.
Fixes <https://bugs.gnu.org/49459>. * gnu/packages/patches/coreutils-gnulib-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/base.scm (coreutils)[source]: Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/base.scm3
-rw-r--r--gnu/packages/patches/coreutils-gnulib-tests.patch45
3 files changed, 48 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index adb4ad2e55..901fc7c4ba 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -928,6 +928,7 @@ dist_patch_DATA = \
%D%/packages/patches/combinatorial-blas-awpm.patch \
%D%/packages/patches/combinatorial-blas-io-fix.patch \
%D%/packages/patches/connman-CVE-2021-33833.patch \
+ %D%/packages/patches/coreutils-gnulib-tests.patch \
%D%/packages/patches/coreutils-ls.patch \
%D%/packages/patches/cpufrequtils-fix-aclocal.patch \
%D%/packages/patches/crawl-upgrade-saves.patch \
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 565d2ccab8..93e83979f7 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -328,7 +328,8 @@ used to apply commands with arbitrarily long arguments.")
(sha256
(base32
"1yjcrh5hw70c0yn8zw55pd6j51dj90anpq8mmg649ps9g3gdhn24"))
- (patches (search-patches "coreutils-ls.patch"))))
+ (patches (search-patches "coreutils-ls.patch"
+ "coreutils-gnulib-tests.patch"))))
(build-system gnu-build-system)
(inputs `(("acl" ,acl) ; TODO: add SELinux
("attr" ,attr) ;for xattrs in ls, mv, etc
diff --git a/gnu/packages/patches/coreutils-gnulib-tests.patch b/gnu/packages/patches/coreutils-gnulib-tests.patch
new file mode 100644
index 0000000000..7142401202
--- /dev/null
+++ b/gnu/packages/patches/coreutils-gnulib-tests.patch
@@ -0,0 +1,45 @@
+Fix Gnulib test failures showing up on ARMv7:
+
+ https://issues.guix.gnu.org/49459
+
+This is a backport of this Gnulib commit:
+
+ commit 175e0bc72808d564074c4adcc72aeadb74adfcc6
+ Author: Paul Eggert <eggert@cs.ucla.edu>
+ Date: Thu Aug 27 17:52:58 2020 -0700
+
+ perror, strerror_r: remove unportable tests
+
+ Problem reported by Florian Weimer in:
+ https://lists.gnu.org/r/bug-gnulib/2020-08/msg00220.html
+ * tests/test-perror2.c (main):
+ * tests/test-strerror_r.c (main): Omit unportable tests.
+
+diff --git a/tests/test-perror2.c b/tests/test-perror2.c
+index 1d14eda7be..c6214dd25c 100644
+--- a/gnulib-tests/test-perror2.c
++++ b/gnulib-tests/test-perror2.c
+@@ -79,9 +79,6 @@ main (void)
+ errno = -5;
+ perror ("");
+ ASSERT (!ferror (stderr));
+- ASSERT (msg1 == msg2 || msg1 == msg4 || STREQ (msg1, str1));
+- ASSERT (msg2 == msg4 || STREQ (msg2, str2));
+- ASSERT (msg3 == msg4 || STREQ (msg3, str3));
+ ASSERT (STREQ (msg4, str4));
+
+ free (str1);
+diff --git a/tests/test-strerror_r.c b/tests/test-strerror_r.c
+index b11d6fd9f6..c1dbcf837b 100644
+--- a/gnulib-tests/test-strerror_r.c
++++ b/gnulib-tests/test-strerror_r.c
+@@ -165,9 +165,6 @@ main (void)
+
+ strerror_r (EACCES, buf, sizeof buf);
+ strerror_r (-5, buf, sizeof buf);
+- ASSERT (msg1 == msg2 || msg1 == msg4 || STREQ (msg1, str1));
+- ASSERT (msg2 == msg4 || STREQ (msg2, str2));
+- ASSERT (msg3 == msg4 || STREQ (msg3, str3));
+ ASSERT (STREQ (msg4, str4));
+
+ free (str1);