summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDhruvin Gandhi <contact@dhruvin.dev>2021-03-22 18:29:16 +0530
committerJelle Licht <jlicht@fsfe.org>2023-05-29 16:22:33 +0200
commitcf78f5b54975679df97c3015a541114d8278f417 (patch)
tree6b1156d9622b30d2b0243797cfc06dd5c05cda42 /gnu
parent7b400e7f8751e6b0cc6e66d3f7ecfb7f5bd51309 (diff)
gnu: Add node-global-gradle-clean.
* gnu/packages/node-xyz.scm (node-global-gradle-clean): New variable. Signed-off-by: Jelle Licht <jlicht@fsfe.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index a9784dbf7a..6c16417309 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;; Copyright © 2021 Charles <charles.b.jackson@protonmail.com>
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2021 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Jelle Licht <jlicht@fsfe.org>
;;;
@@ -251,6 +252,30 @@ multiple node.js files, while providing useful information about output and exit
codes.")
(license license:expat)))
+(define-public node-global-gradle-clean
+ (package
+ (name "node-global-gradle-clean")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/VarunBarad/global-gradle-clean")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fhm4jimnf7bl5drgwg39mjh8x4rns15hl0fz3bnxi9ikc6dm02y"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f)) ;No tests.
+ (home-page "https://github.com/VarunBarad/global-gradle-clean")
+ (synopsis "Global Gradle Clean")
+ (description
+ "Global Gradle Clean is a Node.js package used to clean all gradle
+projects under a given directory. It uses the gradle wrapper to execute the
+clean task of each project.")
+ (license license:expat)))
+
(define-public node-long-stack-traces
(package
(name "node-long-stack-traces")