summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 09:45:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:43 +0100
commitd610a77e88a1b329c895563173c1912135309928 (patch)
tree9da34501a59674915c7a7afba17dd6323b6f4973 /gnu
parent8b2d5e33c9ba7d6874a619342743faeac77b328c (diff)
gnu: go-github-com-mattn-go-zglob: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mattn-go-zglob): Move from here ... * gnu/packages/golang-xyz.scm: ... to here * gnu/packages/password-utils.scm: Add (gnu packages golang-xyz) module. Change-Id: I3777ff257c6baa91930e141f84f9da94be0634b6
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm22
-rw-r--r--gnu/packages/password-utils.scm1
3 files changed, 27 insertions, 23 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7a14a0367f..62829a8715 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4,9 +4,10 @@
;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
-;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
+;;; Copyright © 2019, 2021 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019-2021 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020, 2021 raingloom <raingloom@riseup.net>
@@ -1920,6 +1921,30 @@ string.")
the @code{cpan} module @code{Parse::CommandLine}.")
(license license:expat)))
+(define-public go-github-com-mattn-go-zglob
+ (package
+ (name "go-github-com-mattn-go-zglob")
+ (version "0.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mattn/go-zglob")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1923lvakm66mzy62jmngdvcmbmiqclinsvnghs3907rgygnx1qc1"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/mattn/go-zglob"))
+ (home-page "https://github.com/mattn/go-zglob")
+ (synopsis "Glob library that descends into other directories")
+ (description
+ "This package provides a glob library that implements descending into
+other directories. It is optimized for filewalking.")
+ (license license:expat)))
+
(define-public go-github-com-miekg-dns
(package
(name "go-github-com-miekg-dns")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b6d435af7a..ba358a02bb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6601,28 +6601,6 @@ improved and cleaner API.")
Proxy functionality.")
(license license:expat)))
-(define-public go-github-com-mattn-go-zglob
- (package
- (name "go-github-com-mattn-go-zglob")
- (version "0.0.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mattn/go-zglob")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1923lvakm66mzy62jmngdvcmbmiqclinsvnghs3907rgygnx1qc1"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/mattn/go-zglob"))
- (home-page "https://github.com/mattn/go-zglob")
- (synopsis "Glob library that descends into other directories")
- (description "A glob library that implements descending into other
-directories. It is optimized for filewalking.")
- (license license:expat)))
-
(define-public go-github-com-mattn-go-sqlite3
(package
(name "go-github-com-mattn-go-sqlite3")
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 1dbf138ad4..eb64a7f306 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -94,6 +94,7 @@
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-crypto)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages kerberos)