summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-24 14:10:37 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:08:15 +0100
commitdd96805c888bc924a7bc42d39bc098c9791ab633 (patch)
treec3e5e072e02cb420a56fe533dfe67a558a40cc22 /gnu
parent1915c363744fbfc90c6eddcf70de89addaf62644 (diff)
gnu: Remove ocaml4.07-cstruct.
* gnu/packages/ocaml.scm (ocaml4.07-cstruct): Remove variable. (ocaml-cstruct)[properties]: Remove variant. Change-Id: I623e2947aa9a597d9ee1342f27c7ec98d171b05e
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 0 insertions, 17 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f320e7f760..e218d27ec7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4852,7 +4852,6 @@ big- and little-endian, with their unsafe counter-parts.")
(list ocaml-bigarray-compat))
(native-inputs
(list ocaml-alcotest))
- (properties `((ocaml4.07-variant . ,(delay ocaml4.07-cstruct))))
(home-page "https://github.com/mirage/ocaml-cstruct")
(synopsis "Access C structures via a camlp4 extension")
(description "Cstruct is a library and syntax extension to make it easier
@@ -4860,22 +4859,6 @@ to access C-like structures directly from OCaml. It supports both reading and
writing to these structures, and they are accessed via the Bigarray module.")
(license license:isc)))
-(define-public ocaml4.07-cstruct
- (package-with-ocaml4.07
- (package
- (inherit ocaml-cstruct)
- (version "5.1.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mirage/ocaml-cstruct")
- (commit (string-append "v" version))))
- (file-name (git-file-name "ocaml-cstruct" version))
- (sha256
- (base32
- "0jj3whs8r3jc524i9bb67rffh7y7r157hjgvws0bkxijxpjzwkbk"))))
- (properties '()))))
-
;; TODO again, the "parent" package already has an explicit package argument,
;; so a variant package doesn't make sense, at least these aliases help the
;; importer out so it doesn't re-import things. At least hopefully.