summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-09-06 14:23:50 -0700
committerRicardo Wurmus <rekado@elephly.net>2023-09-20 16:38:44 +0200
commite05c225ffbc6decb8294d30dfb0776284025c19f (patch)
tree599920aa91db51a7373e53808393624ea7c7160b /gnu
parent6bd17a0806ad32d1493ac51a7443276f719c4224 (diff)
gnu: Add wasm-micro-runtime.
* gnu/packages/web.scm (wasm-micro-runtime): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 980663fae9..631106028d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -63,6 +63,7 @@
;;; Copyright © 2022 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2023 Christopher Howard <christopher@librehacker.com>
+;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1710,6 +1711,42 @@ other systems that want to manipulate WebAssembly files.")
(description "WASM3 is a fast WebAssembly interpreter.")
(license license:expat)))
+(define-public wasm-micro-runtime
+ (package
+ (name "wasm-micro-runtime")
+ (version "1.2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bytecodealliance/wasm-micro-runtime")
+ (commit (string-append "WAMR-" version))))
+ (file-name (git-file-name "WAMR" version))
+ (sha256
+ (base32
+ "1s7r8vfxixf737jp12cf7as68fd63lrmqdxj7fiqdla2wk89ly3f"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ ;; Running the tests is difficult. The test script in
+ ;; tests/wamr-test-suites insists on downloading and building wabt (even
+ ;; if we provide it) and it has a hard time accepting a separately
+ ;; provided clone of the https://github.com/WebAssembly/spec repository.
+ ;; Future releases provide unit tests which may be easier to run.
+ #:tests? #false
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "product-mini/platforms/linux"))))))
+ (home-page "https://bytecodealliance.github.io/wamr.dev")
+ (synopsis "WebAssembly Micro Runtime")
+ (description "WebAssembly Micro Runtime (WAMR) is a lightweight standalone
+WebAssembly (Wasm) runtime with small footprint, high performance and highly
+configurable features for applications cross from embedded, IoT, edge to
+Trusted Execution Environment (TEE), smart contract, cloud native and other
+features.")
+ (license license:asl2.0)))
+
(define-public websocketpp
(package
(name "websocketpp")