summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-10-01 22:12:15 +0200
committerAndrew Tropin <andrew@trop.in>2023-10-02 16:55:04 +0400
commite45f9b4b1251df1a51a30e1d4a53fc2075abfcfe (patch)
tree477ed15d718980f502509ca240671423f3eaf63e /gnu
parent3b71b2dca78c3df3bb6cc952c0911293359a4247 (diff)
gnu: emacs-buttercup: Fix native comp tests with emacs-next.
* gnu/packages/emacs-xyz.scm (emacs-buttercup): Add patch emacs-buttercup-fix-native-comp-pretty-test. * gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch: Add file. * gnu/local.mk: Add emacs-buttercup-fix-native-comp-pretty-test.patch. Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/emacs-xyz.scm4
-rw-r--r--gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch32
3 files changed, 36 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a53701c673..07feef909e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1095,6 +1095,7 @@ dist_patch_DATA = \
%D%/packages/patches/elm-reactor-static-files.patch \
%D%/packages/patches/elogind-fix-rpath.patch \
%D%/packages/patches/emacs-all-the-icons-remove-duplicate-rs.patch \
+ %D%/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch \
%D%/packages/patches/emacs-deferred-fix-number-of-arguments.patch \
%D%/packages/patches/emacs-exec-path.patch \
%D%/packages/patches/emacs-ess-fix-obsolete-function-alias.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2e0b094d85..9cb64e7e1c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28521,7 +28521,9 @@ targets the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.)")
(file-name (git-file-name name version))
(sha256
(base32
- "1rvc9r6swb74lhzd877jidkkf2cxl5v4zz302j2imqhsbk844qzh"))))
+ "1rvc9r6swb74lhzd877jidkkf2cxl5v4zz302j2imqhsbk844qzh"))
+ (patches
+ (search-patches "emacs-buttercup-fix-native-comp-pretty-test.patch"))))
(build-system emacs-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch b/gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch
new file mode 100644
index 0000000000..677d5e2303
--- /dev/null
+++ b/gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch
@@ -0,0 +1,32 @@
+From 0f822190360a99bac6b532058beb5e20cb2673c3 Mon Sep 17 00:00:00 2001
+From: Nicolas Graves <ngraves@ngraves.fr>
+Date: Sun, 1 Oct 2023 20:20:03 +0200
+Subject: [PATCH] test: Change `pretty' test regexp to pass tests on emacs 30.
+
+---
+ tests/test-buttercup.el | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/tests/test-buttercup.el b/tests/test-buttercup.el
+index d68787b..a2e3ba7 100644
+--- a/tests/test-buttercup.el
++++ b/tests/test-buttercup.el
+@@ -2009,9 +2009,15 @@ text properties using `ansi-color-apply'."
+ "suite bc-bt-backtrace\n"
+ "\n"
+ "Traceback (most recent call last):\n"
+- "λ (bc-bt-foo \"" (regex ,long-string) "\")\n"
+- "λ (bc-bt-bar \"" (regex ,long-string) "\")\n"
+- "λ (bc-bt-baz \"" (regex ,long-string) "\")\n"
++ (seq
++ "λ (bc-bt-foo \"" (regex ,long-string) "\")"
++ (optional "\n"))
++ (seq
++ "λ (bc-bt-bar \"" (regex ,long-string) "\")"
++ (optional "\n"))
++ (seq
++ "λ (bc-bt-baz \"" (regex ,long-string) "\")"
++ (optional "\n"))
+ (* (seq (or ?M ?λ) " (" (* not-newline) ; frame start
+ (*? (seq "\n " (* not-newline))) ; any number of pp lines
+ (* not-newline) ")\n")) ;; frame end