summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-07 11:09:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-07 11:09:42 +0100
commite8f4ce74280f035c2224875602bb06e3b59ed746 (patch)
treeda7fa46701926fddc13c8bc87eea89dc3a727655 /gnu
parentfb3dfff677e5610897fd0154d764aa9ec208c2e3 (diff)
gnu: azr3: Update to 1.2.3-1.3391a0a.
* gnu/packages/audio.scm (azr3): Update to 1.2.3-1.3391a0a. [arguments]: Replace bootstrap phase. * gnu/packages/patches/azr3-remove-lash.patch, gnu/packages/patches/azr3.patch: Update patches.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm82
-rw-r--r--gnu/packages/patches/azr3-remove-lash.patch2
-rw-r--r--gnu/packages/patches/azr3.patch12
3 files changed, 53 insertions, 43 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 132a1018ce..e7065c2f53 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1091,46 +1091,56 @@ formant warp.")
(license license:gpl2+)))
(define-public azr3
- (package
- (name "azr3")
- (version "1.2.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://savannah/ll-plugins/azr3-jack-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "18mdw6nc0vgj6k9rsy0x8w64wvzld0frqshrxxbxfj9qi9843vlc"))
- (patches (search-patches "azr3.patch"
- "azr3-remove-lash.patch"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:tests? #f ; no check target
- #:make-flags
- #~(list "LV2PEG=ttl2c"
- (string-append "prefix=" #$output)
- (string-append "pkgdatadir=" #$output "/share/azr3-jack"))
- #:phases
- '(modify-phases %standard-phases
- (add-before 'install 'fix-timestamp
- (lambda _
- (let ((early-1980 315619200)) ; 1980-01-02 UTC
- (utime "azr3.1" early-1980 early-1980)))))))
- (inputs
- (list gtkmm-2 lvtk jack-1))
- (native-inputs
- (list pkg-config))
- (home-page "http://ll-plugins.nongnu.org/azr3/")
- (synopsis "Tonewheel organ synthesizer")
- (description
- "AZR-3 is a port of the free VST plugin AZR-3. It is a tonewheel organ
+ (let ((commit "3391a0a509e7fa3fb46c7627fd5979b67e468038")
+ (revision "1"))
+ (package
+ (name "azr3")
+ (version (git-version "1.2.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/ll-plugins/azr3-jack.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09wy0z4kiid7mwf5b5j8rzzgxafi4mg88xs550n7864p0n351chx"))
+ (patches (search-patches "azr3.patch"
+ "azr3-remove-lash.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no check target
+ #:make-flags
+ #~(list "LV2PEG=ttl2c"
+ (string-append "prefix=" #$output)
+ (string-append "pkgdatadir=" #$output "/share/azr3-jack"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (call-with-output-file "Makefile.config"
+ (lambda (port) (display "" port)))
+ (substitute* "Makefile"
+ (("^PACKAGE_VERSION =.*")
+ (string-append "PACKAGE_VERSION = \"" #$version "\"\n")))))
+ (add-before 'install 'fix-timestamp
+ (lambda _
+ (let ((early-1980 315619200)) ; 1980-01-02 UTC
+ (utime "azr3.1" early-1980 early-1980)))))))
+ (inputs
+ (list gtkmm-2 lvtk jack-1))
+ (native-inputs
+ (list pkg-config))
+ (home-page "http://ll-plugins.nongnu.org/azr3/")
+ (synopsis "Tonewheel organ synthesizer")
+ (description
+ "AZR-3 is a port of the free VST plugin AZR-3. It is a tonewheel organ
with drawbars, distortion and rotating speakers. The organ has three
sections, two polyphonic sections with nine drawbars each and one monophonic
bass section with five drawbars. A standalone JACK application and LV2
plugins are provided.")
- (license license:gpl2)))
+ (license license:gpl2))))
(define-public calf
(package
diff --git a/gnu/packages/patches/azr3-remove-lash.patch b/gnu/packages/patches/azr3-remove-lash.patch
index d62bd1e93c..d5d481c5dd 100644
--- a/gnu/packages/patches/azr3-remove-lash.patch
+++ b/gnu/packages/patches/azr3-remove-lash.patch
@@ -19,7 +19,7 @@ index 7c9f4f0..f82ba75 100644
textbox.hpp textbox.cpp
azr3_SOURCEDIR = azr3
-azr3_CFLAGS = `pkg-config --cflags gtkmm-2.4 jack lash-1.0` -DDATADIR=\"$(pkgdatadir)\"
--azr3_LDFLAGS = `pkg-config --libs gtkmm-2.4 jack lash-1.0`
+-azr3_LDFLAGS = `pkg-config --libs gtkmm-2.4 jack lash-1.0` -lpthread
+azr3_CFLAGS = `pkg-config --cflags gtkmm-2.4 jack` -DDATADIR=\"$(pkgdatadir)\"
+azr3_LDFLAGS = `pkg-config --libs gtkmm-2.4 jack` -lpthread
azr3_cpp_CFLAGS = $(shell if pkg-config --atleast-version=0.107 jack ; then echo -include azr3/newjack.hpp; fi)
diff --git a/gnu/packages/patches/azr3.patch b/gnu/packages/patches/azr3.patch
index 5849383c5b..93e9b5b11a 100644
--- a/gnu/packages/patches/azr3.patch
+++ b/gnu/packages/patches/azr3.patch
@@ -68,9 +68,9 @@ The patch has been sent to the developer on 2016-09-26.
Widget* eb = add_clickbox(m_fbox, 14, 319, 14, 44);
eb->signal_button_press_event().
- connect(sigc::hide(bind(bind(mem_fun(*this, &AZR3GUI::change_mode),
-- ref(m_fbox)), false)));
+- sigc::ref(m_fbox)), false)));
+ connect(sigc::hide(sigc::bind(sigc::mem_fun(*this, &AZR3GUI::change_mode),
-+ false, std::ref(m_fbox))));
++ false, sigc::ref(m_fbox))));
m_fx_widgets.push_back(eb);
// Mr Valve controls
@@ -79,15 +79,15 @@ The patch has been sent to the developer on 2016-09-26.
Widget* eb2 = add_clickbox(m_vbox, 14, 53, 14, 44);
eb2->signal_button_press_event().
- connect(sigc::hide(bind(bind(mem_fun(*this, &AZR3GUI::change_mode),
-- ref(m_fbox)), true)));
+- sigc::ref(m_fbox)), true)));
+ connect(sigc::hide(sigc::bind(sigc::mem_fun(*this, &AZR3GUI::change_mode),
-+ true, std::ref(m_fbox))));
++ true, sigc::ref(m_fbox))));
// vibrato controls
add_switch(m_vbox, n_1_vibrato, 39, 17, Switch::Green);
@@ -352,9 +352,9 @@
knob->set_style(s);
- if (port >= 0 && port < m_adj.size()) {
+ if (port < m_adj.size()) {
knob->get_adjustment().signal_value_changed().
- connect(compose(bind<0>(mem_fun(*this, &AZR3GUI::control_changed), port),
- mem_fun(knob->get_adjustment(),
@@ -100,7 +100,7 @@ The patch has been sent to the developer on 2016-09-26.
}
@@ -382,8 +382,8 @@
db->set_style(s);
- if (port >= 0 && port < m_adj.size()) {
+ if (port < m_adj.size()) {
db->get_adjustment().signal_value_changed().
- connect(compose(bind<0>(mem_fun(*this, &AZR3GUI::control_changed), port),
- mem_fun(db->get_adjustment(), &Adjustment::get_value)));