summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-08-09 21:12:18 +0200
committerAndrew Tropin <andrew@trop.in>2023-08-11 09:02:13 +0400
commite6c6014f03e26f87898b39e87bc88a3b61c773ca (patch)
tree14e39307b2ef6a126efa0c9975e90830cc732451 /gnu
parent56fddefc6de3b0c1f2ccb9559d86ba08d2e429b9 (diff)
gnu: Add emacs-sway.
* gnu/packages/emacs-xyz.scm (emacs-sway): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed3d89d51f..2d7fbe20b5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12208,6 +12208,32 @@ The following completions are currently available:
@end itemize")
(license license:gpl3+)))
+(define-public emacs-sway
+ ;; Commit from Nicola's fork (dash free version with various improvments)
+ (let ((commit "838ef531a30fe616f0141adbdabc132d4edfd374")
+ (revision "0"))
+ (package
+ (name "emacs-sway")
+ (version (git-version "0.6.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thblt/sway.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ddaz8my3z4ca2z81kf1h8773pyx8h0l0ra3ssqd1rq5j0041wdh"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/thblt/sway.el")
+ (synopsis "Communication with the Sway window manager")
+ (description
+ "This is a basic library to control the Sway window manager from Emacs.
+Its main use case is in combination with popup managers like Shackle, to
+use frames instead of windows while still giving focus to existing frames
+instead of duplicating them.")
+ (license license:gpl3+))))
+
(define-public emacs-sweet-theme
(let ((commit "78f741806ecebe01224bf54d09ad80e306652508")
(revision "0"))