summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-09-23 23:50:28 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-27 18:36:00 +0000
commit02c43445544426aa4eebfd08289161509bc21460 (patch)
tree8cf3c5e43681775377f7d32b5f5a575e12dfa5a1 /gnu
parent38df0c033403a6ce9d330ae32a551a81ef44a822 (diff)
gnu: gusb: Don't build introspection data when cross-compiling.
This fixes a configure error when cross-compiling and doesn't cause any rebuilds. * gnu/packages/gnome.scm (gusb)[arguments]<#:configure-flags>: Set 'introspection' and 'vapi' to false. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 497713cddc..47eb552603 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6573,7 +6573,14 @@ DAV, and others.")
`(("glib" ,glib)
("libusb" ,libusb)))
(arguments
- `(#:tests? #f)) ;libusb fails to initialize. Wonder what that is.
+ `(#:tests? #f ;libusb fails to initialize. Wonder what that is.
+ #:configure-flags
+ ,(if (%current-target-system)
+ ;; Introspection data cannot currently be cross-compiled.
+ ''("-Dintrospection=false"
+ ;; Requires introspection data.
+ "-Dvapi=false")
+ ''())))
(home-page "https://github.com/hughsie/libgusb")
(synopsis "GLib binding for libusb1")
(description