summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:31:24 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit10e614523f7af4e3b9ee45da01dcb11f2c827c18 (patch)
tree25d2d7d2e07d1716b05150b0e3c9e2e85197f50a /gnu
parentca41c155c5ea510fc75c2924327446959b89a359 (diff)
gnu: Add ghc-cereal.
* gnu/packages/haskell.scm (ghc-cereal): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c29f1bf1d9..d1edef698e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1219,6 +1219,28 @@ Haskell.")
modifying, and extracting files from zip archives in Haskell.")
(license bsd-3)))
+(define-public ghc-cereal
+ (package
+ (name "ghc-cereal")
+ (version "0.4.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/cereal/cereal-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "15rhfn9hrjm01ksh9xpz9syxsp9vkvpp6b736iqq38wv2wb7416z"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/cereal")
+ (synopsis "Binary serialization library")
+ (description "This package provides a binary serialization library,
+similar to @code{binary}, that introduces an @code{isolate} primitive for
+parser isolation, and labeled blocks for better error messages.")
+ (license bsd-3)))
+
(define-public ghc-appar
(package
(name "ghc-appar")